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Import the Model
1. Open CADfix
2. Navigate to folder
3. Change File type to “STEP”
4. Highlight “V22 Example Model_cf.stp”
5. Check “Import Only” box
6. Click “Go”
7. Rotate and Inspect the imported Model
Create the Major Sets from the Hierarchy
1. Click the hierarchy icon [image: ] on the left, then the assembly button[image: ]
2. Type “SETA BLADES Z2” in the command window.
3. Type “SETA DIELECTRICS Z4” in the command window.
4. Type “SETA BOXES Z6” in the command window.
5. Type “SETA FUSEL Z8” in the command window.
6. Type “SETA CABLE Z10” in the command window.
Create the Lightning Attach Channel
1. Open the tools menu [image: ] on the left
2. Click build->create/edit lines
3. Open the “Swept line” tool [image: ]
4. Click in the “Sweep Point” dialog box, then select a point on the tip of the nose of the helicopter
[image: ]
5. Under the “Vector/Axis” heading, check the “Define” button
6. In the “Define Vector/Axis” popup, select the “Absolute” button
7. Type “4.0” in the “dZ” translation box.
8. Click “OK”
[image: ]
9. Click “Apply”
10. Note the Line Name noted below, such as [image: ]
11. Type “PLUS LA WFB2” in the command window, where WFB2 is the name of the newly created line.
12. Type “SETA ATTACH WFB2” in the command window, where WFB2 is the name of the newly created line.
Create the Lightning Detach Channel
1. Open the tools menu [image: ] on the left
2. Click build->create/edit points
3. Type -2.66, 1.536, and -18.5 in the X, Y, Z coordinate box as shown:
[image: ]
4. Click “Apply”
5. Note the name of the Point Name noted below, such as [image: ]
6. Type “PLUS PA TCI9” in the command window, where TCI9 is the name of the newly created point.
7. Click build->create/edit lines
8. Use the “Two Points” method
[image: ]
9. Click in the “Pnt 1” box, then select the point on the right aft stabilizer as shown:
[image: ]
10. In the “Pnt 2” box, enter “TCI9”, where TCI9 is the name of the newly created point above.
11. Note the name of the newly created line below, such as [image: ]
12. Type “PLUS LA WFB3” in the command window, where WFB3 is the name of the newly created line.
13. Type “SETA DETACH WFB3” in the command window, where WFB3 is the name of the newly created line.
Specify Units, Define Lattice, and Mesh Geometry
1. Type “RNAM UNIT” in the command window.
2. Open Tools->Toolbox->EMA3D_#2_SpecifyUnits, as shown below:
[image: ]

3. Click “Units” [image: ] from the right side of the screen. 
4. Select the “meters (m)” radio button.
5. Click “OK”

6. Open Tools->Toolbox->EMA3D_#3_DefineLattice, as shown below:
[image: ]
7. Select “ConLatt” [image: ] from the right side of the screen.
8. Enter the following lattice parameters:
X = -17 to 17 
∆X = 0.1
Y = -3 to 8.9
∆Y = 0.1
Z = -18.5 to 6.5
∆Z = 0.1

[image: ]
9. Click “OK”
10. Type “PLUS LATE” 
11. Make sure the lattice surrounds the entire craft with a few meters of padding on each side.












12. Open Tools->Toolbox->EMA3D_#5_MeshGeometry.
[image: ]
13. Select “Mesh” [image: ] from the right menu.
14. Type “PLOT TWI ALL” in the command window and inspect the mesh to make sure everything is present
Define Time Step
1. Open Tools->Toolbox->EMA3D_#6_DefineTimeStep.
2. Select “TimeStep” [image: ] from the right menu.
3. Enter “1.5 x 10-10” in the “Time Step (s)” field.
4. Enter “2,000,001” in the “Number of Time Steps” field, as shown below.

[image: ]
5. Click “OK”
Define the Materials
1. Open Tools->Toolbox->EMA3D_#8_DefineProperties.
2. Select “PROPERTY” [image: ] from the right menu.
3. Click “New” in the “EMA3D Property Editor” window.
4. In the “Name” field of the “New Property” window, type “IBOX”
5. In the “Type” spin box, change the definition to “Isotropic Body” as shown below
[image: ]
6. Click “OK”
7. In the “Isotropic Body” popup window, enter “1E-3” in the “Electric Conductivity” field.
8. Leave the other fields as the default, as shown below:
[image: ]
9. Click “OK”
10. Click “New” in the “EMA3D Property Editor” window.
11. In the “Name” field of the “New Property” window, type “THNW”.
12. In the “Type” spin box, change the definition to “MHARNESS Cable”.
13. Click “OK”
14. Review the default values of the pop-up window and click “OK”. 
15. Click “New” in the “EMA3D Property Editor” window.
16. In the “Name” field of the “New Property” window, type “WSHI”.
17. In the “Type” spin box, change the definition to “Isotropic Surface”.
18. Click “OK”
19. In the “Isotropic Surface” popup window, enter “0.015” in the “Electric Conductivity” field.
20. Leave the other fields as the default.
[image: ]
21. Click “OK”
22. Click “New” in the “EMA3D Property Editor” window.
23. In the “Name” field of the “New Property” window, type “TPEC”.
24. In the “Type” spin box, change the definition to “PEC Surface”.
25. Click “OK”
26. In the “PEC Surface” popup, click “OK”
[image: ]
27. Click “New” in the “EMA3D Property Editor” window.
28. In the “Name” field of the “New Property” window, type “OCMP”.
29. In the “Type” spin box, change the definition to “Isotropic Surface”.
30. Click “OK”
31. In the “Isotropic Surface” popup window, enter “1E3” in the “Electric Conductivity” field.
32. Leave the other fields as the default.
[image: ]
33. Click “OK”
34. Click “New” in the “EMA3D Property Editor” window.
35. In the “Name” field of the “New Property” window, type “PLIN”.
36. In the “Type” spin box, change the definition to “PEC Line”.
37. Click “OK”
[image: ]
38. In the “PEC Line” popup, click “OK”








Assign the Materials
1. Highlight “IBOX” in the “Property Editor” popup window.
[image: ]
2. Click “Assign” in the “Property Editor” popup window.
3. Type “BOXES” in the “Assign Property” popup window.
[image: ]
4. Click “Apply”
5. Select “TPEC” in the “Name of Property” spin box of the “Assign Property” popup window.
6. Type “BLADES” in the “Assign Property” popup window.
7. Click “Apply”
8. Select “THNW” in the “Name of Property” spin box of the “Assign Property” popup window.
9. Type “CABLE” in the “Assign Property” popup window.
10. Click “Apply”
11. Select “WSHI” in the “Name of Property” spin box of the “Assign Property” popup window.
12. Type “DIELECTRICS” in the “Assign Property” popup window.
13. Click “Apply”
14. Select “OCMP” in the “Name of Property” spin box of the “Assign Property” popup window.
15. Type “FUSEL” in the “Assign Property” popup window.
16. Click “Apply”
17. Select “PLIN” in the “Name of Property” spin box of the “Assign Property” popup window.
18. Type “DETACH” in the “Assign Property” popup window.
19. Click “OK”
20. Click “Close” in the “Property Editor” window.
Define Sources
1. Open Tools->Toolbox->EMA3D_#10_DefineSources.
2. Select “Source_Tool” [image: ] from the right menu.
3. In the “EMA Source Tool” field, change the “Time Step” to “1.000e-08”.
4. In the “Final Time” field, change the value to “3.000e-04”
5. Click “Plot Source”
6. The results should be the same as below:
[image: ]
7. Click “Finished”.
8. Click “OK”.
9. Type “PRNT L ATTACH” in the command window.
10. Note the name of the line echoed, such as “WFB2”
11. Type “SETA ATTACH N WFB2” in the command window, where WFB2 is the name of the line echoed in the previous step.
12. Select “EleCurDen” [image: ] from the right menu.
13. Enter “dexp.dat” in the “Source File Name” field of the “Macro ELE_CUR_DEN_SOURCE Parameters” popup window.
14. Enter “ATTACH” in the “Set of Nodes to be Loaded” field of the “Macro ELE_CUR_DEN_SOURCE Parameters” popup window.
15. Enter “1.0” in the “Z-Component Multiplier” field of the “Macro ELE_CUR_DEN_SOURCE Parameters” popup window.
16. Leave the other parameters at the default, as shown below:
[image: ]
17. Click “OK”
18. Notice that in the window below, in the “Set of Nodes to be Loaded” box, the dash has not been replaced by “ATTACH”. This will cause the source to not load properly.
[image: ]
Select Boundary Condition
1. Open Tools->Toolbox->EMA3D_#11_SelectBdyConds.
2. Select “BOUND” [image: ] from the right menu.
1. 
2. 
3. Click the “MURL (HFLD)” radio button in the “All” column of the “Boundary Conditions” popup window
[image: ]
4. Click “APPLY”.
Define Surface Current Probes
1. Type the following into the command line:
RNAM SJSA
RNAM STP1
SETA SJSA S ALL
COMP SJSA GN
SETR SJSA S ALL
SETA STP1 L ALL
COMP STP1 GN
SETR SJSA STP1
2. Type “PLOT TWI SJSA” into the command line and observe the aircraft nodes.
3. Select “Traditional” [image: ] from the right menu.
4. Type “SJSA” in the “Set Name” field.
5. Click the “JS” radio button in the “Output type” field
6. Type “3E-4” in the “Stop time” field
7. Type “2E-6” in the Step time” field, as shown in the figure below:
[image: ]
8. Click “OK”
Create Cable Harness Model
1. Type “PLOT LA CABLE” into the command window.
2. Open Tools->Toolbox->EMA3D_#9_MHARNESS_Cables.
3. Select “MHlnFiCre” [image: ] from the right menu.
4. Review the splash page of the window and click “Next”.
5. Type “heli_cable.inp” into the “INP File Name” box.
6. Type "CABLE" into the "CADfix set name" box.
7. Select 2 levels of shielding from the spin box, as shown below:[image: ]
8. Click “Next” to advance to the “System Level 2 Segments and Boundary Conditions Window”
9. Make sure that the Line Pick tool is activated. If not, click in the box until it is highlighted yellow.
10. Click the line “VZNO” or the line that is displayed from the CABLE set.
11. Make sure that the Point Pick tool is activated. If not, click in the box until it is highlighted yellow.
12. Click the endpoints of “VZNO” or the line that is displayed from the cable set.
13. Make sure that only “Resistive” is checked in the boundary condition list.
14. Set the end impedance to 2.5E-3 Ohms.
15. Click “No” for the second boundary condition radio button, as shown below:
[image: ]
16. Click "Next".
17. In the “Segment Name, Junction and Source Info for line VZNO” window, where VZNO is the name of the main cable, change the “Segment Name” field to “avionicscab”.
18. Leave the Junction name for both points at “0”.
19. Leave “Segment bottom height above ground (m)” at 0.001 m, as shown below:
[image: ]
20. In the “System Level 1 Info” window, enter “14” in the "total number of system level 1 conductors" box.
21. Click “Next” to advance to the “System level 1 conductor 1 segments” window.
22. Make sure that the Line Pick tool is activated. If not, click in the box until it is highlighted yellow.
23. Click the line “VZNO” or the line that is displayed from the CABLE set.
24. Make sure that the Point Pick tool is activated. If not, click in the box until it is highlighted yellow.
25. Click the endpoints of “VZNO” or the line that is displayed from the cable set.
26. Make sure that only “Resistive” is checked in the boundary condition list.
27. Set the end impedance to 2.5E-3 Ohms.
28. Click “No” for the second boundary condition radio button, as shown below:
[image: ]
29. Click “Next” to advance to the “System level 1 – Conductor 1 parameters for line VZNO” window, where VZNO is the line in the CABLE set.
30. Change the wire gauge to “22” AWG in the spin box.
31. Select "Twisted Shielded Pair, (TSP)"  in the "type of inner conductor(s)" spin box.
32. Note the assumed parameters for this type of TSP is auto-filled in the form, as shown below:
[image: ]
33. Click “Next” to advance to the “System level 0 boundary conditions for System level 1 conductor 1” window.





34. Review the default values as shown below:
[image: ]
35. Click “Next” to advance to the “System level 1 conductor 2 segments” window.
36. Click the “yes” radio button for the question “Does system level 1 conductor 2 have the same routing, termination points and boundary conditions as system level 1 conductor 1?”.
37.  Click the “yes” radio button for the question “Does system level 1 conductor 2 have the same wire gauge, wire type and inner boundary conditions as system level 1 conductor 1?”.
38. Enter "13" in the "number of copies of conductor 1" box,  as shown below:
[image: ]
39. Click “Next”.
40. On the “Cable Pack for Shield Level 1” page that appears click "Back" once.
41. In the “System level 0 boundary conditions for System level 1 conductor 14” window, change the “END of conductor 1” and “END of conductor 2” resistances to “1.0e+6”, as shown below:
[image: ]
42. Click “Next” to advance to the “Cable Pack for Shield Level 1” window.
43. Click “Next” to launch Cable Pack.
44. Click the increment shield [image: ] button until the braid surround all TSP edges, as shown below:
[image: ]
45. Click the “Write out and exit” button [image: ] to return to the MHARNESS user interface.
46. Click “OK” in the popup window.
47. Observe the default values in the “Shield level 2 info for line VZNO” window, where VZNO is the line in the CABLE set.
48. Click “Next” to enter the “Connector Information” window.
49. Leave the “no” radio button selected.
50. Click “Next” to enter the “Probe Info” window.
51. Enter 4 in the total number of probes box.
52. Click “Next to enter the “Probe 1 Info” window.
53. Change the “Probe Output File Name” to “braid_current.dat”
54. Leave the “Probe start time” at “0.0”
55. Leave the “Probe stop time” at “0.00030000015”
56. Change the “Probe step time” to “1.0e-007”
57. Change the segment to collect probe data to “VZNO”, where VZNO is the name of the line in the CABLE set.
58. Change the “Select the type of probe” spin box to “Shield Two Current”
59. Change the probe location spin box to “Middle Cell”
[image: ]
60. Click “Next to enter the “Probe 2 Info” window.
61. Change the “Probe Output File Name” to “tsp_current.dat”
62. Leave the “Probe start time” at “0.0”
63. Leave the “Probe stop time” at “0.00030000015”
64. Change the “Probe step time” to “1.0e-007”
65. Change the segment to collect probe data to “VZNO”, where VZNO is the name of the line in the CABLE set.
66. Change the “Select the type of probe” spin box to “Shield One Current”
67. Change the probe location spin box to “Middle Cell”
68. Click the "Check System Level 1 Conductors" [image: ] button.
69. Enter the system level 1 conductor number “13” in the final input box, as shown below:
[image: ]
70. Click “Next to enter the “Probe 3 Info” window.
71. Change the “Probe Output File Name” to “pin_current_sc.dat”
72. Leave the “Probe start time” at “0.0”
73. Leave the “Probe stop time” at “0.0001”
74. Change the “Probe step time” to “1.0e-007”
75. Change the segment to collect probe data to “VZNO”, where VZNO is the name of the line in the CABLE set.
76. Change the “Select the type of probe” spin box to “Cable Current”
77. Change the probe location spin box to “Middle Cell”
78. Click the "Check System Level 1 Conductors" button.
79. Enter the system level 1 conductor number “13” in the next input box.
80. Click the "Check System Level 0 Conductors" button.
81. Enter the system level 0 conductor number “1” in the final input box, as shown below:
[image: ]
82. Click “Next to enter the “Probe 4 Info” window.
83. Change the “Probe Output File Name” to “pin_voltage_oc.dat”
84. Leave the “Probe start time” at “0.0”
85. Leave the “Probe stop time” at “0.0001”
86. Change the “Probe step time” to “1.0e-007”
87. Change the segment to collect probe data to “VZNO”, where VZNO is the name of the line in the CABLE set.
88. Change the “Select the type of probe” spin box to “Cable Voltage”
89. Change the probe location spin box to “End Cell”
90. Click the "Check System Level 1 Conductors" button.
91. Enter the system level 1 conductor number “14” in the final input box.
92. Click the "Check System Level 0 Conductors" button.
93. Enter system level 0 conductor number “2” in the final input box, as shown below:
[image: ]
94. Click “Next” to enter the “File Creation” window.
95. Click “Next” to create the input file.
96. Observe the confirmation window and click “OK”.
97. Click the “MHlnFiNam” [image: ] button.
98. Enter “heli_cable.inp”, the name of the MHARNESS file just created, and click “OK”.
99. Click the “MHSegAsn” [image: ] button.
100. Enter “CABLE” in the “Harness Set Name” box and click “OK”.

Prepare the 3D Simulation Input File
1. Open Tools->Toolbox->EMA3D_ReviewTool.
2. Select “Review” [image: ] from the right menu.

3. The following window will appear.

[image: ]
4. Review the simulation details, and click “Create EMA3D Input File”  [image: ] when ready to proceed.
5. Note the file name and click “OK” in the popup window.
Run EMA3D Simulation Serial (For Parallel Simulation skip this section)
1. Open Tools->Toolbox->EMA3D_Run_EMA3D
2. Select “Run_EMA3D” [image: ] from the right menu.
3. Select the “Run New EMA3D Simulation” radio button.
4. Click “Browse”
5. Select the .emin file by the same name created in the Review step above.
6. Click “Open”
7. Click “Run EMA3D”
8. Wait for the simulation to complete. Observe the progress of the plot by clicking on the probe table items. The window is shown below:
[image: ]
Run EMA3D Simulation Parallel
1. Save and Close Cadfix
2. Open a task manager and click on the performance tab. The graphic in the upper right-hand corner labeled “CPU Usage History” will show you how many CPU cores you have available to run the problem on.
[image: \\EPSILON\Users\Anthony\Pictures\coreNum.png]
3. The computer this demo was run on has 24 core available, but for this example only 12 will be used.
4. Open the EMA3D_Training_V22_Example.emin in any text editor
5. Edit the Line under !MPI BLOCKS from “ 1   1    1”  to an even distribution of the number of processors you are going to run this on, for example since this computer will run the problem on 12 cores the line will be changed to “2     2     3”. It is important to note that this distribution will most likely not be the fastest way to solve this problem. The fastest way to solve the problem can be found by running the first 15 – 20 time steps of the problem using different distributions in the !MPI BLOCKS section such as “1     2    6”, “2    1    6” and so on.
[image: ]
[image: ]
6. Open a command prompt window and navigate to the folder you were working out of.
7. Type “mpiexec –n # ema3d EMA3D_Training_V22_Example.emin” where “#” is the number of cores you are running the problem on, in the case of the computer the example was run on this would be 12.
8. Hit Enter and the program should begin. If this is your first time running MPI the program will ask for an account user name and password, this is just the user name and password for the computer you are using. Once that information is entered the program should begin.
9. EMA3D will warn you that part of the source has been ignored, this is ok, type in “Y” and hit enter and the program will begin to run the simulation. Note that this may take anywhere from a few hours to a few days depending on your hardware.
Run MHARNESS Cable Model

1. Open the EMA3D_Training_V22_Example.fbm with CADfix.
2. Open Tools->Toolbox->EMA3D_MHARNESS.
3. Select “Run_MH” [image: ] from the right menu.
4. Click the “Run New MHARNESS Simulation” radio button.
5. Click “Browse”
6. Select “heli_cable.inp” and click “Open”
7. Click “Run MHARNESS”
8. Analyze the probe results when complete. For example, the pin voltage as a function of time is below:
[image: ]
Create Surface Current Density Animation
1. Save the CADfix database.
2. Close CADfix
3. Open Windows Start menu and click run. On Windows 7, type directly in the Start Menu search box.
4. Type “cmd.com” to open a command window.
5. Type “cd /d <folder location>”, where <folder location> refers to the working directory from above.
6. Type “famfromema3d” into the command window.
7. Type the name of the .emin file, such as “V22_Example Model_cf”.
8. An example of the command line execution is below:
[image: ]
9. Open the CADfix database file saved above, such as “V22_Example_Model_cf.fbm”
10. Click the post-processing tab on the left side of the CADfix window [image: ]
11. Wait on the database to load.
12. Check to ensure the traditional probe of set “SJSA” is visible for each time point, as shown below:
[image: ]
13. Type "CHEC" to make sure that the results database matches the model.
14. Type “RNAM RD01” into the command window.
15. Type “RNAM RD02” into the command window.
16. Open View->Display Settings and open the “Mesh” tab
17. Change the “Element edge colour” to “off”
18. Change the “Mesh shrink factor” to “off”
[image: ]
19. Click “OK”
20. Navigate back to the Post Processing tab [image: ]
21. Click on one of the Traditional probe values to reveal its data parts.
[image: ]
22. Click on the non-time value so that it is highlighted.
23. Click on the Animate button to bring up the next animation window.
[image: ]
24.  Next Click the “Contour range” button. 
[image: ]
25. Click “OK” on the warning that pops up. Select the “User defined” radio button in the “To” section and enter “7e4” in the entry box and click Apply.
[image: ]

26. The Animation window will contain a list of all SJSA data points. Click the "Select All" button. Then Click the "Capture" button.
[image: ]

27. A new window should appear showing the progress of the animation being created. During this time the CADfix window should be slowly advancing, frame by frame, showing the animation that is being created.

[image: ]
28. When the animation ends a video editor window will appear, from here the video can be edited, formatted and saved as desired.
[image: ][image: ]
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