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Model 1 - Imported box with display, 
vent holes, connectors and seams 

Import the Model 
1. Open CADfix 

2. Open File -> Preferences and make sure the “Generate long entity names” option is checked as 

shown below: 

 
3. Navigate to the appropriate folder 

4. Change File type to CADfix GDX 

5. Highlight avionics_training.gdx 



6. Check Import Only button 

7. Click Go 

8. Rotate and Inspect the imported Model 

Specify Units 
1. Open Tools -> Toolbox -> EMA3D_#2_SpecifyUnits 

2. Click Units from the right side of the screen.  

3. Select the millimeters (mm) radio button. 

4. Click OK 

Create the Major Sets from the Hierarchy 

1. Click the hierarchy icon  on the left, then the assembly button at the bottom  

2. Type SETA SEAMS Z2 in the command window. 

3. Type SETA TRACES Z4 in the command window. 

4. Type SETA CARDS Z6 in the command window. 

5. Type SETA CASE Z8 in the command window. 

6. Type SETA HOLES Z10 in the command window. 

Geometric Tolerance Check and Menu Command Guide Viewing 
1. Examine the model -> PLOT G ALL 

2. Plot surfaces with assigned colors -> PLUS SI ALL ASGD 

3. Check the geometric tolerance -> PROC GTOL 

4. Set the geometric tolerance to be 0.01 mm -> PROC GTOL 0.01 

5. Make sure the CADfix menu is on to help guide CADfix command structure -> PLOC MENU ON 

6. The menu may not appear, to show the menu, click the hide/show arrow tab , at the upper 

left hand region of the graphics window 

 

 

Initial Model Cleanup and Revision Control 
1. Eliminate duplicate Points, Lines, Surfaces and Shapes by using the MERG command 

MERG P ALL GTOL NOLOCK 



MERG L ALL GTOL SIMPLE MINSLOP 0.0 

MERG S ALL GTOL EQSH 

MERG SH ALL GTOL (takes a minute or so) 

2. Save the model as avionics_training_mod1.fbm 

Original Set Cleanup and Inspection Using Clipping Planes 
1. Observe that the CARDS are in both the CARDS set and the CASE set  

2. PLOT G CASE 

3. PLUS SI CASE ASGD 

4. Use clipping planes to inspect CASE interior -> CLIP BOTH AUTO 

5. Press F9 on the keyboard to activate/deactivate clipping planes 

6. Press and hold the left mouse button and slide the mouse left or right to control the position of 

the near clipping plane  

7. Press and hold the center (scroll button) mouse button and slide the mouse left or right to 

control the position of the far clipping plane  

8. Press and hold the right mouse button and slide the mouse left or right to control the position of 

the both clipping planes at the same time  

9. Position the near clipping plane so that the cards inside of the box can be seen 

10. Notice that the cards inside of the box appear dark in color on one side of the card, shade both 

orientations of surfaces to better see the CARDS surfaces ->PLOC SHAD BOTH 

11. Repaint the image -> REP 

12. Plot the surfaces of the CARDS set to realize that the CARDS surfaces are in both the CASE and 

CARDS set -> PLUS SI CARDS C 

13. Remove the CARDS from the CASE set -> SETR CASE CARDS 

14. Wipe the CARDS surfaces from the plotted image -> WIPE -1 

15. Observe that the CARDS are no longer in the CASE set 

16. Turn clipping planes off -> CLIP BOTH OFF 

Create Connectors Set 
1. Create a set for connectors using QADD command -> QADD CONNECTORS 

2. Type A to adjust geometry 

3. Type N to create multiple points around the connectors and generate a new geometry 

4. When the surrounding geometry is nearly completed, type W to include only whole entities 

5. Type S to grab all surfaces inside of the newly defined geometry 

6. Investigate the newly created CONN set -> PLOT G CONNECTORS , PLUS SI CONNECTORS ASGD 

7. Complete the connector set down to add all points, lines and surfaces that are used to create 

the connector surfaces -> COMP CONNECTORS 

8. Remove the original connectors set from the CASE set -> SETR CASE CONNECTORS 

Add modified Connectors to the Case 
1. Connectors J1 and J2 will be represented for simulation 

2. Include the geometry of the case for reference -> PLUS G CASE 



3. Make sure that the GMER option is off in CADfix -> PROC GMER OFF 

4. Select the 2 lines U7216 and U7217 that form the outline for the interior channel of J1 using the 

Probe: Lines select tool as shown below: 

 
5. Right click in the probe entity window and chose make a new temporary set called TEMP1 

  
6. Copy the TEMP1 set of lines into the set CONNJ1 -> COPY TEMP1 CONN1 

7. Plot the lines of the CONNJ1 set -> PLUS LA CONNJ1 B 

8. Open the CONNJ1 set -> SETO CONNJ1 

9. Now sweep the 2 lines in CONNJ1 so that they meet the end of the metal connector inside of 

the box using the menu point to point SWEP commands to select the points with the mouse 

cursor -> SWEP CONNJ1 ! TRA Q4743 Q4715 



  
10. Close the CONNJ1 set -> SETC CONNJ1 

11. Copy the CONNJ1 Set to the J2 (CONNJ2) position using the Move/Copy, set manager technique 

in CADfix as shown below.  

12. Click the Move/Copy tool in the CADfix Build tools on the left side of the screen. 

 
13. Click the drop down menu to select the Pick: Surface option: 



 
14. Click the list manager button in the upper right hand corner 

 
15. Click the Set Manager button in the Pick Part(s) window: 

 
 

16. In the Source drop-down menu, select the Surfaces from another SET… option: 



 
 

17. Select the CONNJ1 set and click OK 

 
18. Click Close in the Set Manager Window 

19. Notice the highlighted surfaces are V3002 and V3003 and click OK 

20. Click the two points option the Vector / Axis section of the window and select the two inside 

wall points of connectors J1 and J2, Q5312 and Q1111  



 
 

21. Click Apply to complete the copy sequence 

22. Click Apply -> Type CONNJ2 for the name of the new part and click OK 

23. Plot the case and newly created connectors -> 

PLOT G CASE 

PLUS SI CASE ASGD 

PLUS G CONNJ1 B 

PLUS G CONNJ2 B 

PLUS SI CONNJ1 C 

PLUS SI CONNJ2 C 

Split Connector Surfaces with Front Case Surface 
1. Open the CONNJ1 set -> SETO CONNJ1 

2. Click the Split surfaces with a plane tool as shown below:plus 



 
 

3. Select the 2 surfaces of the newly created connector CONNJ1 in the Pick surfaces section: 

 
 

4. Click the Define a new splitting plane button for the Splitting plane section 



 
 

5. Select three corner points on the face to define the plane as shown below: 

 
 

6. Click Apply in the Create Shape window. 

7. Click Apply in the Split surfaces with a plane window. 

8. A window should pop up indicating that 4 new surfaces have been created.  Click OK. 



 
 

9. Close the CONNJ1 set -> SETC CONNJ1 

10. Open the CONNJ2 set -> SETO CONNJ2 

11. Repeat the above process to split the CONNJ2 surfaces 

12. Close the set CONNJ2 after the surfaces have been split -> SETC CONNJ2 

Modify the Case Face with Connectors 
1. Open the CASE set -> SETO CASE 

2. Remove the J1-J8 labels from the case surface using the surface edit tool as shown below. 

3. Click the Edit button and select surface V1260. 

4. Click the Remove box. 

5. Click the box select tool to envelope all of the connector labels at once and remove them from 

the surface definition. 



 

6. Uncheck the Remove box in the lower right corner 

7. Click the newly created connector lines that lay on surface V1260. 

 

8. Click Apply 

9. In the Define embedding shape window, make sure the Existing button is selected and click OK 

10. Notice the holes that have been created on the box surface in the connector channels 

11. Save the model as avionics_training_mod2.fbm 



Add Display Panel 
1. Create a new point -> PNT ! -50 100 0 

2. Sweep the new point to make a line -> SWEP Q5697 ! TRA 0 75 0 

3. Sweep the new line to make a surface -> SWEP U7889 ! TRA 150 0 0 

4. Type -> REP 

5. Edit the front face surface of the CASE to exclude the new Panel surface area  

6. Do this by adding the new lines to the surface definition in the Create/edit Surfaces tool: 

 
7. Click Apply  

8. Click OK when the Define embedding shape window pops up. 

9. Add the display surface to a set called PANEL -> SETA PANEL V3014 

10. Remove the display panel from the CASE set -> SETR CASE PANEL 

11. Close all sets -> SETC ALL 

12. Repaint the image and notice that the display panel is gone from the image -> REP 

Add Vent Holes to Top Panel 
1. Create lines that will be used as thin gaps to represent a grid of vent holes with the following 

commands: 

SETO VENTS 

SETO TEMP2 

PNT ! -65 250 -135 

SWEP Q5701 ! TRA 10 0 0 

COPY U7893 ! TRA 15 0 0 8 



COPY TEMP2 ! TRA 0 0 10 7 

SETC TEMP2 

SETC VENTS 

PLUS L VENTS B 

2. Observe the lines on top of the box that will be a grid of vents 

Create the Dipole Source 
1. Create the lines for the dipole source using the following commands: 

SETO SOURCE 

PNT ! 0  100 150 

SWEP Q5845 ! TRA 0 5 0 

SETC SOURCE 

SETO DIPOLE 

SWEP Q5846 ! TRA 0 15 0 

SWEP Q5845 ! TRA 0 -15 0 

SETC DIPOLE 

 

Make Master Mesh Set 
1. Create a master set that contains all of the components necessary for meshing and EMA3D 

analysis by adding previously defined sets to BOX: 

SETA BOX CARDS CASE CONNJ1 CONNJ2 

SETA BOX DIPOLE HOLES PANEL SEAMS  

SETA BOX SOURCE TRACES VENTS 

PLOT G BOX 

PLUS SI BOX ASGD 

Define Lattice and Mesh Geometry 
1. Open Tools->Toolbox->EMA3D_#3_DefineLattice 

2. Select ConLatt from the right side of the screen. 

3. Enter the following lattice parameters: 



 
4. Click OK 

5. Plot the lattice of the problem space -> PLUS LATE  

6. Make sure the lattice surrounds the entire box with a few millimeters of padding on each side. 

7. Make sure the geometric tolerance is still set to 0.01 -> PROC GTOL 0.01 

8. Open Tools->Toolbox->EMA3D_#5_MeshGeometry. 

9. Click the Mesh button 

10. If geometry is changed or only the master mesh set is to be meshed, click the Setup button to 

prepare the mesh and type -> MESH BOX 

11. Go to View -> Display Settings -> Mesh and set the edge color to Black and shrink factor both to 

Off 

 
12. Click OK 

13. Inspect the mesh to make sure everything is present -> PLOT TWI BOX 



14. Save the model as avionics_training_mod3.fbm 

 

Define Time Step 
1. Open Tools->Toolbox->EMA3D_#6_DefineTimeStep. 

2. Select TimeStep from the right menu. 

3. Enter 7.5e-12 in the Time Step (s) field. 

4. Enter 13,333 in the Number of Time Steps field, as shown below. 

 

 
5. Click OK 

Define the Properties 
1. Open Tools->Toolbox->EMA3D_#8_DefineProperties. 

2. Select PROPERTY from the right menu. 

3. Click New 

4. In the Name field of the New Property window, type PECL 



5. In the Type spin box, change the definition to PEC Line, as shown below 

 

6. Click Ok in the New Property window. 

7. Click Ok in the PEC Line window. 

8. Click New 

9. In the Name field of the New Property window, type PECS 

10. In the Type spin box, change the definition to PEC Surface, as shown below 

 

11. Click Ok in the window that pops up. 

12. Click Ok in the PEC Surface window. 

13. Click New 

14. In the Name field of the New Property window, type TWIR as shown below. 

 
15. In the Type spin box, change the definition to Thin Wire. 

16. Click OK 

17. In the Thin Wire popup window, enter 0.5 in the Radius field. 

18. Leave the other fields as the default, as shown below: 



 
19. Click OK 

20. Click New 

21. In the Name field of the New Property window, type DIPS. 

22. In the Type spin box, change the definition to Thin Wire. 

23. Click OK 

24. Change the START Termination Type to 1 - Parallel 

25. Change the START Termination Resistance to 50 (Ohms) 

26. Leave the other fields as the default, as shown below: 

 



27. Click OK 

28. Click New in the EMA3D Property Editor window. 

29. In the Name field of the New Property window, type ALUM. 

30. In the Type spin box, change the definition to Isotropic Surface. 

31. Click OK 

32. In the Isotropic Surface popup, enter 2.5e7 in the Electric Conductivity field, as shown below: 

 
33. Click OK 

34. Click New in the EMA3D Property Editor window. 

35. In the Name field of the New Property window, type TGAP. 

36. In the Type spin box, change the definition to Thin Gap. 

37. Click OK 

38. In the Thin Gap popup window, enter 0.001 in the Gap Width field, as shown below: 

 
39. Click OK 

40. Click New in the EMA3D Property Editor window. 

41. In the Name field of the New Property window, type SEAM1. 

42. In the Type spin box, change the definition to Seam. 

43. Click OK 

44. In the Seam popup window, enter the Resistance, Inductance and Capacitance values as shown 

below: 



 
45. Click OK 

46. Click New in the EMA3D Property Editor window. 

47. In the Name field of the New Property window, type DIEL. 

48. In the Type spin box, change the definition to Isotropic Surface. 

49. Click OK 

50. In the Isotropic Surface popup, enter 1.8e-11 in the Permittivity field, as shown below: 

 
51. Click OK 

Assign the Materials 
1. Use the Property Editor to assign the materials to the appropriate sets. 

2. Highlight PECS in the Property Editor window. 

3. Click Assign in the Property Editor window. 

4. Type HOLES in the Assign Property window. 

 
5. Click Apply 

6. Use PECS again, type CASE in the Assign Property popup window. 

7. Click Apply 



8. Select TWIR in the Name of Property spin box of the Assign Property popup window. 

9. Type TRACES in the Assign Property popup window. 

10. Click Apply 

11. Select ALUM in the Name of Property spin box of the Assign Property popup window. 

12. Type CARDS in the Assign Property popup window. 

13. Click Apply 

14. Type CONNJ1 in the Assign Property popup window. 

15. Click Apply 

16. Type CONNJ2 in the Assign Property popup window. 

17. Click Apply 

18. Select DIEL in the Name of Property spin box of the Assign Property popup window. 

19. Type PANEL in the Assign Property popup window. 

20. Click Apply 

21. Select PECL in the Name of Property spin box of the Assign Property popup window. 

22. Type DIPOLE in the Assign Property popup window. 

23. Click Apply 

24. Select TGAP in the Name of Property spin box of the Assign Property popup window. 

25. Type VENTS in the Assign Property popup window. 

26. Click Apply 

27. Select SEAM1 in the Name of Property spin box of the Assign Property popup window. 

28. Type SEAMS in the Assign Property popup window. 

29. Click Apply 

30. Select DIPS in the Name of Property spin box of the Assign Property popup window. 

31. Type SOURCE in the Assign Property popup window. 

32. Click Apply 

33. Click Close in the Assign Property popup window. 

34. Click Close in the Property Editor window. 

Define Sources 
1. Open Tools->Toolbox->EMA3D_#10_DefineSources 

2. Set the Current File Location to the current working project directory on your machine. 

3. In the Select Analytic Function and Time Values spin box, change the value to Gaussian. 

4. In the EMA Source Tool field, change the Time Step to 1.000e-10. 

5. In the Final Time field, change the value to 1.000e-07 

6. In the A parameter field, change the value to 1.0 

7. In the t0 field, change the value to 1.000e-8 

8. In the Alpha field, change the value to 1.000e+19 

9. Click Plot Source. Note that the frequency domain content goes to about 1 GHz. 

10. The results should be the same as below: 



 
11. Click Finished 

12. Click Ok in the EMA_Source_Tool popup window. 

13. Open Tools->Toolbox->EMA3D_#10_DefineSources 

14. Type PLUS NA SOURCE C 

15. Observe the node number that will be the source at the center of the dipole 

 
 

16. In this case, the node is 34671 

17. Click ThwVol from the right menu (Thin Wire Voltage Source) 

18. Enter gaussian.dat in the Source File Name field  

19. Enter 34671 in the Single Node to be Loaded field as shown below: 



 

20. Click OK 

Select Boundary Condition 
1. Open Tools->Toolbox->EMA3D_#11_SelectBdyConds. 

2. Select BOUND from the right menu. 

3. Click the PML radio button in the Boundary Conditions popup window 

4. Review the default values as shown below and click APPLY 

 

Define Trace Current Probe 
1. Type PLOT LA TRACES 

2. Observe the names of the lines plotted, such as U78567 and U7859. 



 
3. Type SETA TRACE1 N U7857 in the command window, where U7857 is the name of one of the 

lines echoed above. 

4. Type SETA TRACE2 N U7859 in the command window, where U7859 is the name of one of the 

other lines echoed above. 

5. Open Tools->Toolbox->EMA3D_#12_DefineProbes. 

6. Select New from the right menu. 

7. Input TRACE1 in the New Probe Set Name field under Step (1) 

8. Input 1e-6 in the Stop Time field under Step (5) 

9. Input 1e-10 in the Step Time field under Step (5), as shown below 

 

10. Click APPLY 

11. Input TRACE2 in the New Probe Set Name field under Step (1) 

12. Input 1e-6 in the Stop Time field under Step (5) 

13. Input 1e-10 in the Step Time field under Step (5) 

14. Click APPLY 

15. Now, create two points to associate with an electric field probe inside and outside of the box. In 

the command window, type  

PNT FIPR1 0 100 50 

PNT FIPR2 0 100 -100 

SETA FIELDPR1 FIPR1 

SETA FIELDPR2 FIPR2 

ASG FIPR1 PH EXCP 

ASG FIPR2 PH EXCP 

16. Return to the New Probe #2 dialog box. 

17. Type FIELDPR1 in the New Probe Set Name field (1) 



 
18. Retain a Start Time of 0.0, a Stop Time of 1e-6 and a Step Time of 1e-10 

19. Click APPLY 

20. Change the New Probe set name to FIELDPR2 

21. Click OK 

Define Surface Current Probes for Animation 
1. Type the following into the command line: 

RNAM SJSA 
RNAM STP1 
SETA SJSA S BOX 
COMP SJSA GN 
SETR SJSA S BOX 
SETA STP1 L BOX 
COMP STP1 GN 
SETR SJSA STP1 



 
2. Type PLOT TWI SJSA into the command line and observe the box twinkles that will be used for 

surface current density animation. 

3. Select Traditional from the right menu. 

4. Type SJSA in the Set Name field. 

5. Select JS in the Output type field. 

6. Type 1E-7 in the Stop time field. 

7. Type 5E-9 in the Step time field, as shown in the figure below: 

       
8. Click OK 

Define Slice Probe 
1. Click Slice in the right hand menu 

2. Type SLIPR1 in the Set Name field. 

3. Select Tan E in the Field Type field. 

4. Select Time in the Plot Type field. 

5. Type 1e-8 in the Start time field. 

6. Type 1e-7 in the Stop time field 

7. Type 1e-8 in the Step time field. 

8. Type 90 in the Polar Angle field. 

9. Type 0 in the Azimuthal Angle field. 

10. Select X for the Normal Direction to Slices field. 

11. Select Percent in the Start Definition field. 

12. Type 50 for the Start Percentage field. 

13. Select Percent in the Cutaway Region field. 

14. Type 50  0  0 for the Starting Percentages (x y z) field. 

15. Type 100  100  100 for the Ending Percentages (x y z) field. 

16. The information in the Slice Probe window should look as follows: 



 
17. Click OK 

18. Save the model as avionics_training_mod4.fbm 

Prepare the 3D Simulation Input File 
1. Open Tools->Toolbox->EMA3D_ReviewTool. 

2. Select Review from the right menu. 

3. The Model Review Tool should contain the same elements as shown below: 



 
4. Review the simulation details, and click FTE when ready to proceed. 

5. Note the file name and click OK in the popup window. 

 
6. Click OK in the EMA3D Input File Creation Procedure window. 

7. Click Close in the EMA3DREV window 

Run EMA3D Simulation 
1. Open Tools->Toolbox->EMA3D_Execute 

2. Select EMA3D_exe from the right menu. 

3. Select the Run New EMA3D Simulation radio button. 

4. Click Browse 

5. Select the .emin file by the same name created in the FTE step above. 



6. Click Open 

7. Click Run EMA3D 

8. Click the Toggle Details button to observe the command prompt sequence produced by EMA3D. 

9. Wait for the simulation to complete. Observe the progress of the plot by clicking on the probe 

table items. The window is shown below: 

 
 

10. Highlight 4 New Probe from the list at the top right 

11. Click Analyze Probe. 

12. Click Plot on Update. 

13. Observe the noisy electric field inside of the box. 

14. Double click 1 New Probe 

15. Highlight 3 IW from the Active Probe Table. 

16. Click Plot on Update 

17. The cable current as a function of time is displayed in the EMA3D Probe Plot, as shown below.  

 



 
18. Investigate the other probes using the same procedure. 

Open a Slice Probe to View Fields Inside of the Box 
1. Use a file browser to navigate to the folder where the simulation was run 

2. Open the post script file “avionics_training_mod4spr1-timepict000001.ps” with a post script 

viewer like GSiew, which is the graphical interface for the postscript interpreter Ghostscript, or 

RoPS Postscript Viewer 

3. Observe that at 1e-8 s the source waveform has not yet fully spread throughout the problem 

space. 



 
4. Open the post script file “avionics_training_mod4spr1-timepict000003.ps” 

5. Notice that by 20 ns, the electric fields inside of the metal box are larger than the ones on the 

outside 

6. The slice probe is approximately displaying the angle and orientation of the box as shown below. 

The image is using clipping planes to visualize the cards in the box interior. 

 



 

Create Surface Current Density Animation 
1. Save the CADfix database. 

2. Close CADfix 

3. Open Windows Start menu and click run. On Windows 7, type directly in the Start Menu search 

box. 

4. Type cmd.com to open a command window. 

5. Type cd /d <folder location>, where <folder location> refers to the working directory from 

above. 

6. Type famfromema3d into the command window. 

7. Type the name of the .emin file, such as avionics_training_mod4 and press enter. 

8. An example of the command line execution is below: 



 
9. Open the CADfix database file saved above, such as avionics_training_mod4.fbm 

10. Click the post-processing tab on the left side of the CADfix window  

11. Wait on the database to load. 

12. Check to ensure the traditional probe of set SJSA is visible for each time point, as shown below: 

 
13. Type CHEC to make sure that the results database matches the model. 

14. Observe that the Result and model databases are consistent as shown below: 



 
15. Type RNAM RD01 into the command window. 

16. Type RNAM RD02 into the command window. 

17. Open View->Display Settings and open the Mesh tab 

18. Change the Element edge colour to off 

19. Change the Mesh shrink factor to off 

 
20. Click OK 

21. Open Tools->Toolbox->EMA3D_PostProcessing. 

22. Select “Animation”  from the right menu. 

23. In the “Probe Set Name” field, enter “SJSA” 

24. In the “Data Set Type” field, select the “JS” radio button. 

25. Click the “Yes” radio button in the “Customize Legend” field. 

26. Set the “Maximum Value in Legend” to “0.0001” 

27. Set the “Legend Gradient Factor (in dB)” to “3.0” 

28. Set the “Record Stop” to “20” 



29. Click the “Yes” radio button in the “Create Carousel” field. 

30. In the “Carousel Name” field, type “!” 

31. In the “Time Interval Between Frames (Sec):”, type “0.1” 

32. Leave the other values at the default, as shown below: 

 

33. Click Play 

34. Type PLAY C1 to run the animation 

Plot the Simulation Data using Spyder 
1. If the WinPython program is not already on the computer you are using, download it from the 

following website for free: http://sourceforge.net/projects/winpython/files/ 

2. The 2.7 version of WinPython seems to be more stable at this time and that is the version 

recommended for installation. 

3. Navigate to the WinPython folder installed on your machine: C:\Program Files (x86)\WinPython-

64bit-2.7.6.4 

http://sourceforge.net/projects/winpython/files/


4. Open the Spyder.exe program 

5. Open the supplied file: plot_avionics_training_data.py 

6. Click the  run file button at the top of the window 

 
7. Observe the results data plots 


